VLAN grund

I denna laboration utforskar vi vlan-teknik. Syftet är att skapa två VLAN ska skapas och “trunka” eller routa datatrafiken. Poängen med VLAN är att ansluta nätverksenheter till switchar och organisera de i olika LAN genom att skapa Virtuella LAN. Switcharna är 2960

Beskrivning Kommando
S1 grundkonfigurationer.

  • Kopiera raderna nedan till Notepad (ingen punktlista).
  • Se till att de finns i rader.
  • Kopiera raderna från Notepad
  • Klistra in texten i switcharnas globala konfigurationsläge (använd knappen Paste)
  • hostname S1
  • no ip domain-lookup
  • service password-encryption
  • enable secret enpass
  • banner motd #
  • Unauthorized access is strictly prohibited. #
  • Line con 0
  • password conpass
  • login
  • logging synchronous
  • line vty 0 15
  • password vtypass
  • logging synchronous
  • login
  • exit
S1 VLAN 1 IP-adress
  • S1(config)#int vlan 1
  • S1(config-if)#ip address 192.168.1.11 255.255.255.0
S2 VLAN 1 IP-adress
  • S2(config)#int vlan 1
  • S2(config-if)#ip address 192.168.1.12 255.255.255.0
PC IP-adresser
  • PC-A: 192.168.10.3, 255.255.255.0, 192.168.10.1
  • PC-B: 192.168.10.4, 255.255.255.0, 192.168.10.1
  • PC-C: 192.168.20.3, 255.255.255.0, 192.168.20.1
S1 lediga portar aktiveras av:

  • F0/1 anslutet till S2
  • F0/6 anslutet till PC-A
  • S1(config)#int range fa0/2-5
  • S1(config-if-range)#shutdown
  • S1(config-if-range)#exit
  • S1(config)#int range fa0/7-24
  • S1(config-if-range)#shutdown
  • S1(config-if-range)#exit
  • S1(config)#int range g0/1-2
  • S1(config-if-range)#shutdown
  • S1(config-if-range)#end
S2 lediga portar aktiveras av:

  • F0/1 anslutet till S1
  • F0/11 anslutet till PC-B
  • F0/18 anslutet till PC-C
  • S2(config)#int range fa0/2-10
  • S2(config-if-range)#shutdown
  • S2(config-if-range)#exit
  • S2(config)#int range fa0/12-17
  • S2(config-if-range)#shutdown
  • S2(config-if-range)#exit
  • S2(config)#int range fa0/19-24
  • S2(config-if-range)#shutdown
  • S2(config-if-range)#exit
  • S2(config)#int range g0/1-2
  • S2(config-if-range)#shutdown
  • S2(config-if-range)#end
S1 och S2 konfigurationer lagras till start-config
  • S1#copy run start
IP-trafik testas med ping.
  • Kan PC-A ping till PC-B? Ja
  • Kan PC-A ping till PC-C? Nej
  • Kan PC-A ping till S1? Nej
  • Kan PC-B ping till PC-C? Nej
  • Kan PC-B ping till S2? Nej
  • Kan PC-C ping till S2? Nej
  • Kan S1 ping till S2? Ja
Varför Nej? Det saknas default gateway som kan routa IP-trafiken
S1 VLAN konfiguration
  • S1(config)#vlan 10
  • S1(config-vlan)#name Student
  • S1(config-vlan)#vlan 20
  • S1(config-vlan)#name Faculty
  • S1(config-vlan)#vlan 99
  • S1(config-vlan)#name Management
  • S1(config-vlan)#end
  • S1#show vlan
S2 VLAN konfiguration
  • S2(config)#vlan 10
  • S2(config-vlan)#name Student
  • S2(config-vlan)#vlan 20
  • S2(config-vlan)#name Faculty
  • S2(config-vlan)#vlan 99
  • S2(config-vlan)#name Management
  • S2(config-vlan)#end
  • S2#show vlan
Vilken är default VLAN på switcharna? VLAN 1
Tilldela portar i S1 till VLAN:

  • F0/1 anslutet till S2
  • F0/6 anslutet till PC-A
  • S1(config)#int f0/6
  • S1(config-if)#switchport mode access
  • S1(config-if)#switchport access vlan 10
  • S1#show vlan brief
Flytta VLAN 1 IP-adress till VLAN 99
  • S1(config)#int vlan 1
  • S1(config-if)#no ip address
  • S1(config-if)#int vlan 99
  • S1(config-if)#ip address 192.168.1.11 255.255.255.0
  • S1(config-if)#end
  • S1#show vlan brief
Vilken status har VLAN 99? och varfor Vlan 99 status är up och protokollet down. Detta för att inte någon port har tilldelats till VLAN 99
Tilldela portar i S2 till VLAN:

  • F0/1 anslutet till S1
  • F0/11 anslutet till PC-B
  • F0/18 anslutet till PC-C
  • S2(config)#int f0/11
  • S2(config-if)#switchport mode access
  • S2(config-if)#switchport access vlan 10
  • S2(config)#int f0/18
  • S2(config-if)#switchport mode access
  • S2(config-if)#switchport access vlan 20
  • S2(config-if)#end
  • S2#show vlan brief
Kan nu PC-C ping till PC-A och PC-B? Nej därför att f0/1 porten mellan switcharna har inte konfigurerats än. Dessutom IP-trafiken har flyttats till VLAN 99.
Tilldela portar F0/11-24 i S1 till VLAN 10
  • S1(config)#int range f0/11-24
  • S1(config-if-range)#switchport mode access
  • S1(config-if-range)#switchport access vlan 10
  • S1(config-if-range)#end
  • S1#show vlan brief
Ändra tilldelningen
  • S1(config)#int range f0/11, f0/21
  • S1(config-if-range)#switchport access vlan 10
  • S1(config-if-range)#end
  • S1#show vlan brief
Ta tillbaka port F0/24 från VLAN 10
  • S1(config)#int f0/24
  • S1(config-if)#no switchport access vlan
  • S1(config-if)#end
  • S1#show vlan brief
Skapa på ett anat sätt VLAN 30 och tilldela port F0/24
  • S1(config)#int f0/24
  • S1(config-if)#switchport access vlan 30
  • S1(config-if)#end
  • S1#show vlan brief
Vad får som default namn VLAN 30?
Radera VLAN 30
  • S1(config)#no vlan 30
  • S1(config)#end
  • S1#show vlan brief
Återställa port f0/24
  • S1(config)#int f0/24
  • S1(config-if)#no switchport access vlan
  • S1(config)#end
  • S1#show vlan brief
Kommunikation med DTP mellan switcharna
  • S1(config)#int f0/1
  • S1(config-if)#switchport mode dynamic desirable
  • S1(config)#end
  • S1#show interfaces trunk
Som default VLAN tillåtas i en trunk. Med kommandot switchport trunk hanterar hur VLAN kommunicera.
Trunk konfigurering
  • S1(config)#int f0/1
  • S1(config-if)#switchport mode trunk
  • S2(config)#int f0/1
  • S2(config-if)#switchport mode trunk
  • S2(config-if)#end
  • S2#show int trunk
Radera VLAN database
  • S1#show flash
  • S1#delete vlan.dat
  • S1#show flash
Återställ switcharna till fabrikinställningar
  • S1#erase startup-config
  • S1#reload