RIP

Router Information Protocol är ett distansvektor routing-protokoll som är relativt enkelt att konfigurera. Andra kompletterande aspekter i RIP-konfigurationer kräver uppmärksamhet:

  • Skillnader i versioner 1 och 2
  • Routing-uppdateringar
  • Timers
  • Routing-loopar
  • Route aggregering (summarization)
  • Distribution av statisk routing-information

Vi börjar i denna laboration att grundkonfigurera routrar och switchar och därefter konfigurera RIPv1 och se vad som händer. Därefter konfigurerar vi RIPv2 och studerar skillnader. Routing-konfigurationer kommer att inkludera också statiska route och deras distributionen i ett nätverk styrt av ett dynamiskt routing-protokoll.

Exempel 1

Studera en stund topologin nedan:

Bild 1: RIPv1 grundkonfiguration

Konfigurationer

Syntax

  • Router(config)# router rip
  • Router(config-router)# network <Nätverksadress>
  • R1(config)#router rip
  • R1(config-router)#network 172.30.1.0
  • R1(config-router)#network 172.30.2.0
  • R1(config-router)#passive-interface FastEthernet 0/0
  • R1(config-router)#end
  • R1#show run
  • R1#show ip route
  • R2(config)#router rip
  • R2(config-router)#network 172.30.3.0
  • R2(config-router)#network 172.30.2.0
  • R2(config-router)#network 192.168.4.8
  • R2(config-router)#passive-interface FastEthernet 0/0
  • R2(config-router)#end
  • R2#show run
  • R2#show ip route
  • R3(config-if)#exit
  • R3(config)#router rip
  • R3(config-router)#network 192.168.4.0
  • R3(config-router)#network 192.168.5.0
  • R3(config-router)#passive-interface FastEthernet 0/0
  • R3(config-router)#end
  • R3#show run
  • R3#show ip route

Exempel 2

Studera en stund topologin nedan:

Bild 2: RIPv2 samt statiska route

Konfigurationer

  • Router(config)# router rip
  • Router(config-router)# network <Nätverksadress>
  • Router(config)# ip route 0.0.0.0 0.0.0.0 <nästa hopp adress>
  • Router(config)# ip route <destinationsnätverk> <nätmask> <nästa hopp adress>

Samma konfiguration som i exempel 1

  • R1(config)#router rip
  • R1(config-router)#network 172.30.1.0
  • R1(config-router)#network 172.30.2.0
  • R1(config-router)#passive-interface FastEthernet 0/0
  • R1(config-router)#end
  • R1#show run
  • R1#show ip route

Ta bort konfigurerade routes från exempel 1

  • R2(config)#router rip
  • R2(config-router)#no network 172.30.3.0
  • R2(config-router)#no network 172.30.2.0
  • R2(config-router)#no network 192.168.4.0
  • R2(config-router)#exit
  • R2(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/1
  • R2(config)#end
  • R2#show ip route
  • R3(config)#router rip
  • R3(config-router)#no network 192.168.4.0
  • R3(config-router)#no network 192.168.5.0
  • R3(config)#ip route 172.30.0.0 255.255.252.0 serial 0/0/1
  • R3(config-router)#passive-interface FastEthernet 0/0
  • R3(config-router)#end
  • R3#show run
  • R3#show ip route

Nätverksadressen i kommandot R3(config)#ip route 172.30.0.0 255.255.252.0 serial 0/0/1 är ett resultat av något som kallas “route summarization”. Så här fungerar det:

Nätverksadresser skrivs i binärt format:

  • 172.30.1.0/24= 1010 1100.0001 1110. 0000 0001.0000 0000
  • 172.30.2.0/24 = 1010 1100.0001 1110. 0000 0010.0000 0000
  • 172.30.3.0/24 = 1010 1100.0001 1110. 0000 0011.0000 0000

Matchande bitar identifieras, från vänster till höger

  • 172.30.1.0 = 1010 1100.0001 1110. 0000 0001.0000 0000
  • 172.30.2.0 = 1010 1100.0001 1110. 0000 0010.0000 0000
  • 172.30.3.0 = 1010 1100.0001 1110. 0000 0011.0000 0000

Resterande bitar nollställs

  • 172.30.1.0 = 1010 1100.0001 1110. 0000 0000.0000 0000
  • 172.30.2.0 = 1010 1100.0001 1110. 0000 0000.0000 0000
  • 172.30.3.0 = 1010 1100.0001 1110. 0000 0000.0000 0000

Det avgör den aggregerade nätverksadressen och dess prefix: 172.30.0.0/22

Verifieringar med kommando show ip route kan man konstatera att statiska route inkluderas inte och då propageras inte mellan routrarna. För att tvinga router R2 att propagera statiska route till andra routrar exekvera:

  • R2(config)# router rip
  • R2(config-router)# default-information originate
  • R2(config-router)# end
  • R2# debug ip rip (för att se vad som inkluderas i RIP-uppdateringar)
  • R2# undebug all (stoppa felsökningsläget)