OSPF

I denna laboration konfigureras ett nätverk med routing-protokoll OSPF. Syftet är att lära sig hur OSPF fungerar i ett nätverk som har varierande server- och nätverkstjänster. En viktig del av laborationen illustrerar hur autentisering hanteras.

Beskrivning Kommando
R1 IP-adresser
  • R1(config)# interface fa0/0
  • R1(config-if)# ip address 192.168.1.1 255.255.255.0
  • R1(config-if)# no shutdown
  • R1(config)# interface s0/0/0
  • R1(config-if)# ip address 172.16.1.1 255.255.255.248
  • R1(config-if)#description To R2
  • R1(config-if)# no shutdown
R2 IP-adresser
  • R2(config)# interface fa0/0
  • R2(config-if)# ip address 192.168.2.1 255.255.255.0
  • R2(config-if)# no shutdown
  • R2(config)# interface s0/0/0
  • R2(config-if)# ip address 172.16.1.2 255.255.255.248
  • R2(config-if)# clock rate 64000
  • R2(config-if)# no shutdown
  • R2(config)# inter s0/0/1
  • R2(config-if)# ip address 172.16.1.9 255.255.255.248
  • R2(config-if)# clock rate 64000
  • R2(config-if)# no shutdown
R3 IP-adresser
  • R3(config)#inter fa0/0
  • R3(config-if)#ip address 192.168.3.1 255.255.255.0
  • R3(config-if)#no shutdown
  • R3(config)#inter s0/0/0
  • R3(config-if)#ip address 172.16.1.10 255.255.255.248
  • R3(config-if)#no shutdown
  • R3(config)#inter s0/0/1
  • R3(config-if)#ip address 172.16.1.17 255.255.255.248
  • R3(config-if)#no shutdown
R4 IP-adresser
  • R4(config)#inter fa0/0
  • R4(config-if)#ip address 192.168.4.1 255.255.255.0
  • R4(config-if)#no shutdown
  • R4(config)#inter s0/0/0
  • R4(config-if)#ip address 172.16.1.18 255.255.255.248
  • R4(config-if)#clock rate 64000
R1 OSPF konfiguration
  • R1(config)# router ospf 1
  • R1(config-router)# network 192.168.1.0 0.0.0.255 area 0
  • R1(config-router)# network 172.16.1.0 0.0.0.7 area 0
R2 OSPF konfiguration
  • R2(config)#router ospf 1
  • R2(config-router)#network 192.168.2.0 0.0.0.255 area 0
  • R2(config-router)#network 172.16.1.0 0.0.0.7 area 0
  • R2(config-router)#network 172.16.1.8 0.0.0.7 area 0
R3 OSPF konfiguration
  • R3(config)#router ospf 1
  • R3(config-router)#network 192.168.3.0 0.0.0.255 area 0
  • R3(config-router)#network 172.16.1.8 0.0.0.7 area 0
  • R3(config-router)#network 172.16.1.16 0.0.0.7 area 0
R4 OSPF konfiguration
  • R4(config)#router ospf 1
  • R4(config-router)#network 192.168.4.0 0.0.0.255 area 0
  • R4(config-router)#network 172.16.1.16 0.0.0.7 area 0
R4 DHCP Relay Agent konfiguration
  • R4(config)#inter fa0/0
  • R4(config-if)#ip helper-address 192.168.1.5
R1 AAA för TACACS, RADIUS och LOCAL serverkonfigurationer
  • R1(config)# username admin password cisco
  • R1(config)# aaa new-model
  • R1(config)# tacacs-server host 192.168.1.8 key cisco123
  • R1(config)# radius-server host 192.168.1.9 key cisco123
  • R1(config)# aaa authentication login AD_LOGIN group tacacs+ group radius local
R1 AAA autentisering för Telnet och console uppkopplingar
  • R1(config)#line console 0
  • R1(config-line)# login authentication AD_LOGIN
  • R1(config)# line vty 0 4
  • R1(config-line)# login authentication AD_LOGIN
DNS och DHCP server IP-adress
DNS server konfiguration

Resource Record: SOA

  • DNS service ON
  • Name: diginto.se och Type SOA
  • Primary Server Name ns1.diginto.se och Mail Box: admin@diginto.se
  • Minimum TTL: 3600 och Refresh Time: 1800
  • Retry Time: 800 och Expiry Time 86400
Resource Record: A
  • Name: diginto.se och Type A Record
  • Address: 192.168.1.5
  • Name: mail.diginto.se och Type A Record
  • Address: 192.168.1.7
  • Name: www.diginto.se och Type A Record
  • Address: 192.168.1.6
DHCP serverkonfiguration
  • Interface: FastEthernet 0 och Service ON
  • Pool Name: serverPool
  • Default Gateway: 0.0.0.0
  • DNS Server: 0.0.0.0
  • Start IP Address: 192.168.100.0
  • Subnet Mask: 255.255.255.0
  • Maximum Number of Users: 255
  • TFTP Server: 0.0.0.0
  • WLC Address: 0.0.0.0
  • Pool Name: HQ Kontor
  • Default Gateway: 192.168.1.1
  • DNS Server: 192.168.1.5
  • Start IP Address: 192.168.1.10
  • Subnet Mask: 255.255.255.0
  • Maximum Number of Users: 50
  • TFTP Server: 0.0.0.0
  • WLC Address: 0.0.0.0
  • Pool Name: Branch Kontor
  • Default Gateway: 192.168.4.1
  • DNS Server: 192.168.1.5
  • Start IP Address: 192.168.4.10
  • Subnet Mask: 255.255.255.0
  • Maximum Number of Users: 50
  • TFTP Server: 0.0.0.0
  • WLC Address: 0.0.0.0
HTTP och FTP server IP-adress
  • IP address: 192.168.1.6
  • Subnet Mask: 255.255.255.0
  • Default Gateway: 192.168.1.1
  • DNS server: 192.168.1.5
HTTP serverkonfiguration
  • Service: ON
  • Settings: default
FTP serverkonfiguration
  • Service: ON
  • Username: cisco och Password: cisco
  • Write, Read, Delete, Rename, List
  • Username: ftpuser och Password: 12345
  • Write, Read, Delete, Rename, List
Mail server IP-adress
  • IP address: 192.168.1.7
  • Subnet Mask: 255.255.255.0
  • Default Gateway: 192.168.1.1
  • DNS server: 192.168.1.5
Mail serverkonfiguration
  • SMTP Service: ON
  • POP3 Service: ON
  • Domain Name: diginto.se
  • User: User1 och Password: 12345
  • User: User2 och Password: 12345
  • User: User3 och Password: 12345
TACACS server IP-adress
  • IP address: 192.168.1.8
  • Subnet Mask: 255.255.255.0
  • Default Gateway: 192.168.1.1
  • DNS server: 0.0.0.0
TACACS serverkonfiguration
  • Service: ON och Radius Port: 1645
  • Network Configuration
  • Client Name R1 och Client IP: 192.168.1.1
  • Secret: cisco123 och ServerType: Tacacs
  • User Setup
  • Username: adminr1uno och Password: 12345
  • Username: adminr1dos och Password: 12345
RADIUS server IP-adress
  • IP address: 192.168.1.9
  • Subnet Mask: 255.255.255.0
  • Default Gateway: 192.168.1.1
  • DNS server: 0.0.0.0
RADIUS serverkonfiguration
  • Service: ON och Radius Port: 1645
  • Network Configuration
  • Client Name R1 och Client IP: 192.168.1.1
  • Secret: cisco123 och ServerType: Radius
  • User Setup
  • Username: radius och Password: radius