EIGRP

I denna laboration kombineras EIGRP med statiska route. Syftet är att lära sig det väsentliga av hur EIGRP hanterar statiska route. EIGRP är en routing protokoll som är kapabel att köra flera routing-processer eller instanser. I exemplet används 1 som process/instans identifierare.

Fem 1941/1841 routrar inkluderas i laborationen därav den första till vänster och den sista till höger har flera loopback interface. Dessa interface ska agera som självständiga nätverk med en ansluten host på varje nätverk.

Router R3 är en “boundary router” som pratar EIGRP med samtidigt är den ansluten till andra statiska nätverk. R3 ska inkludera i sina uppdateringar den default route mot R4 så att alla statiska nätverk kan kommas åt.

Konfigurationer

  • Router(config)#router eigrp 1
  • Router(config-router)#no auto-summary
  • Router(config-router)#network <nätverksadress>
  • Router(config)#ip route 0.0.0.0 0.0.0.0 <nästa hopp adress>
  • Router(config-router)#redistribute static metric <64> <100> <255> <1> <1500>

Grundkonfigurationer för Router R1, men även R2, R3, R4 och R5

  • Router(config)#hostname R1
  • R1(config)#enable secret enpass
  • R1(config)#line console 0
  • R1(config-line)#password conpass
  • R1(config-line)#login
  • R1(config)#line vty 0 4
  • R1(config-line)#password vtypass
  • R1(config-line)#login

Interface konfigurationer

  • R1(config)#inter loopback 0
  • R1(config-if)#ip address 172.30.0.1 255.255.255.224
  • R1(config)#inter loopback 1
  • R1(config-if)#ip address 172.30.0.33 255.255.255.224
  • R1(config)#inter loopback 2
  • R1(config-if)#ip address 172.30.0.65 255.255.255.224
  • R1(config)#inter s0/0/0
  • R1(config-if)#ip address 10.1.1.1 255.255.255.252
  • R1(config-if)#no shutdown

EIGRP konfigurationer

  • R1(config)#router eigrp 1
  • R1(config-router)#no auto-summary
  • R1(config-router)#network 172.30.0.0 0.0.0.31
  • R1(config-router)#network 172.30.0.32 0.0.0.31
  • R1(config-router)#network 172.30.0.64 0.0.0.31
  • R1(config-router)#network 10.1.1.0 0.0.0.3

Interface konfigurationer

  • R2(config)#inter s0/0/0
  • R2(config-if)#clock rate 64000
  • R2(config-if)#ip address 10.1.1.2 255.255.255.252
  • R2(config-if)#no shutdown
  • R2(config)#inter s0/0/1
  • R2(config-if)#ip address 10.1.1.6 255.255.255.252
  • R2(config-if)#no shutdown

EIGRP konfigurationer

  • R2(config)#router eigrp 1
  • R2(config-router)#no auto-summary
  • R2(config-router)#network 10.1.1.0 0.0.0.3
  • R2(config-router)#network 10.1.1.4 0.0.0.3

Interface konfigurationer

  • R3(config)#inter s0/0/0
  • R3(config-if)#clock rate 64000
  • R3(config-if)#ip address 10.1.1.5 255.255.255.252
  • R3(config-if)#no shutdown
  • R3(config)#inter s0/0/1
  • R3(config-if)#clock rate 64000
  • R3(config-if)#ip address 10.1.1.9 255.255.255.252
  • R3(config-if)#no shutdown

EIGRP konfigurationer

  • R3(config)#router eigrp 1
  • R3(config-router)#no auto-summary
  • R3(config-router)#network 10.1.1.4 0.0.0.3

Default route konfiguration

  • R3(config)#ip route 0.0.0.0 0.0.0.0 10.1.1.10

Redistribution av statiska route

  • R3(config-router)#redistribute static metric 64 100 255 1 1500
  • 64 – bandwidth kilobits/sec
  • 100 – delay (delas 100/10 = 10 mikrosekunder)
  • 255 – reliability (100% tillförlitlig)
  • 1 – load (255 = 100 belastning, och 1 lite belastning)
  • 1500 – MTU
  • default metric 10000 100 255 1 1500

Interface konfiguration

  • R4(config)#inter s0/0/0
  • R4(config-if)#ip address 10.1.1.10 255.255.255.252
  • R4(config-if)#no shutdown
  • R4(config)#inter s0/0/1
  • R4(config-if)#clock rate 64000
  • R4(config-if)#ip address 10.1.1.13 255.255.255.252
  • R4(config-if)#no shutdown

Statiska route konfigurationer

  • R4(config)#ip route 172.30.0.0 255.255.0.0 10.1.1.9
  • R4(config)#ip route 10.1.1.0 255.255.255.252 10.1.1.9
  • R4(config)#ip route 10.1.1.4 255.255.255.252 10.1.1.9
  • R4(config)#ip route 192.168.0.0 255.255.0.0 10.1.1.14

Interface konfiguration

  • R5(config)#inter s0/0/0
  • R5(config-if)#ip address 10.1.1.14 255.255.255.252
  • R5(config-if)#no shutdown
  • R5(config)#inter loopback 0
  • R5(config-if)#ip address 192.168.5.1 255.255.255.0
  • R5(config)#inter loopback 1
  • R5(config-if)#ip address 192.168.6.1 255.255.255.0
  • R5(config)#inter loopback 2
  • R5(config-if)#ip address 192.168.7.1 255.255.255.0

Default route konfiguration

  • R5(config)#ip route 0.0.0.0 0.0.0.0 10.1.1.13